<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US"> <!--<![endif]-->
<head>
<title>Reports: Musk&#039;s Bid to Buy and Privatize Twitter is Heating up - Somag News</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.somagnews.com/xmlrpc.php" />
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
<link rel="icon" type="image/png" href="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-15.png">

<meta name="description" content="Elon Musk&#039;s offer to buy Twitter is gaining momentum and could be announced as early as Monday, according to media reports about the social network&#039;s" />
<link rel="canonical" href="https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Reports: Musk&#039;s Bid to Buy and Privatize Twitter is Heating up" />
<meta property="og:description" content="Elon Musk&#039;s offer to buy Twitter is gaining momentum and could be announced as early as Monday, according to media reports about the social network&#039;s" />
<meta property="og:url" content="https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" />
<meta property="og:site_name" content="Somag News" />
<meta property="article:publisher" content="https://www.facebook.com/somagnews/" />
<meta property="article:published_time" content="2022-04-25T18:55:21+00:00" />
<meta property="og:image" content="https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg" />
<meta property="og:image:width" content="825" />
<meta property="og:image:height" content="526" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@SoMagNews" />
<meta name="twitter:site" content="@SoMagNews" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.somagnews.com/#organization","name":"Somag News","url":"https://www.somagnews.com/","sameAs":["https://www.facebook.com/somagnews/","https://www.youtube.com/channel/UCdzWimb5As9wbha68JuiNgA?view_as=subscriber","https://twitter.com/SoMagNews"],"logo":{"@type":"ImageObject","@id":"https://www.somagnews.com/#logo","inLanguage":"en-US","url":"https://www.somagnews.com/wp-content/uploads/2019/09/Charcoal-Yellow-Rectangle-Arrrtchitectural-Logo-2-e1568300796902.png","contentUrl":"https://www.somagnews.com/wp-content/uploads/2019/09/Charcoal-Yellow-Rectangle-Arrrtchitectural-Logo-2-e1568300796902.png","width":480,"height":118,"caption":"Somag News"},"image":{"@id":"https://www.somagnews.com/#logo"}},{"@type":"WebSite","@id":"https://www.somagnews.com/#website","url":"https://www.somagnews.com/","name":"Somag News","description":"Hear Everything Instantly!","publisher":{"@id":"https://www.somagnews.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.somagnews.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#primaryimage","inLanguage":"en-US","url":"https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg","contentUrl":"https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg","width":825,"height":526},{"@type":"WebPage","@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#webpage","url":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/","name":"Reports: Musk's Bid to Buy and Privatize Twitter is Heating up - Somag News","isPartOf":{"@id":"https://www.somagnews.com/#website"},"primaryImageOfPage":{"@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#primaryimage"},"datePublished":"2022-04-25T18:55:21+00:00","dateModified":"2022-04-25T18:55:21+00:00","description":"Elon Musk's offer to buy Twitter is gaining momentum and could be announced as early as Monday, according to media reports about the social network's","breadcrumb":{"@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/"]}]},{"@type":"BreadcrumbList","@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.somagnews.com/"},{"@type":"ListItem","position":2,"name":"Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up"}]},{"@type":"Article","@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#article","isPartOf":{"@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#webpage"},"author":{"@id":"https://www.somagnews.com/#/schema/person/04c0b356ad868d8efcd6563b24d6667d"},"headline":"Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up","datePublished":"2022-04-25T18:55:21+00:00","dateModified":"2022-04-25T18:55:21+00:00","mainEntityOfPage":{"@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#webpage"},"wordCount":614,"publisher":{"@id":"https://www.somagnews.com/#organization"},"image":{"@id":"https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#primaryimage"},"thumbnailUrl":"https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg","articleSection":["News"],"inLanguage":"en-US","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.somagnews.com/#organization"}},{"@type":"Person","@id":"https://www.somagnews.com/#/schema/person/04c0b356ad868d8efcd6563b24d6667d","name":"Kaitlyn Kubrick","url":"https://www.somagnews.com/author/kaitlyn-kubrick/"}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Somag News &raquo; Feed" href="https://www.somagnews.com/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.somagnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=540945b58d1a5ddc9ec963b194925237"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.somagnews.com/wp-includes/css/dist/block-library/style.min.css?ver=540945b58d1a5ddc9ec963b194925237' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.somagnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.5.6' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-newsletter-css' href='https://www.somagnews.com/wp-content/plugins/td-newsletter/style.css?ver=11.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.somagnews.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=bcb4f14ba9142ca1fd172c7d9de6043b' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=11.4.3' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css' href='https://www.somagnews.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<link rel='stylesheet' id='tds-front-css' href='https://www.somagnews.com/wp-content/plugins/td-subscription/assets/css/tds-front.css?ver=1.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.somagnews.com/wp-content/themes/Newspaper/style.css?ver=11.4.3' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.somagnews.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=bcb4f14ba9142ca1fd172c7d9de6043b' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.somagnews.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=121f904f8d8fc180b4467ea06478f5a9' type='text/css' media='all' />
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.somagnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.somagnews.com/wp-json/wp/v2/posts/204986" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.somagnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.somagnews.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.somagnews.com/?p=204986' />
<link rel="alternate" type="application/json+oembed" href="https://www.somagnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somagnews.com%2Freports-musks-bid-to-buy-and-privatize-twitter-is-heating-up%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.somagnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somagnews.com%2Freports-musks-bid-to-buy-and-privatize-twitter-is-heating-up%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
        window.tdb_globals = {"wpRestNonce":"868b07a2cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/","globalSettings":{"tdcSavingHistory":false},"isAjax":false,"isAdminBarShowing":false,"autoloadScrollPercent":50,"postAutoloadStatus":"off","origPostEditUrl":null};
    </script>
<style id="tdb-global-colors">
        :root {--accent-color: #fff;}
    </style>
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.somagnews.com\/wp-admin\/","wpRestNonce":"868b07a2cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/www.somagnews.com\/wp-admin\/","wpRestNonce":"868b07a2cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/","postId":204986};
    </script>

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-147729238-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-147729238-1');
</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.somagnews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somagnews.com/news/",
                    "name": "News"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/",
                    "name": "Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up"                                
                }
            }    
        ]
    }
</script>

<style>
    
</style>
<style id="tdw-css-placeholder"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-204986 single-format-standard td-standard-pack reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up global-block-template-1 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/somagnews/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#6a03040c052a1905070b0d040f1d1944090507" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SoMagNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-37361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-37361"><a href="https://www.somagnews.com/">Home</a></li>
<li id="menu-item-112095" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112095"><a href="https://www.somagnews.com/world/">World</a></li>
<li id="menu-item-94731" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94731"><a href="https://www.somagnews.com/entertainment/">Entertainment</a></li>
<li id="menu-item-60799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60799"><a href="https://www.somagnews.com/celebrity/">Celebrity</a></li>
<li id="menu-item-60798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60798"><a href="https://www.somagnews.com/tech/">Tech</a></li>
<li id="menu-item-94730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94730"><a href="https://www.somagnews.com/crypto/">Crypto</a></li>
<li id="menu-item-60801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60801"><a href="https://www.somagnews.com/science/">Science</a></li>
<li id="menu-item-60802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60802"><a href="https://www.somagnews.com/sport/">Sport</a></li>
<li id="menu-item-112093" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112093"><a href="https://www.somagnews.com/health/">Health</a></li>
<li id="menu-item-112094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112094"><a href="https://www.somagnews.com/travel/">Travel</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.somagnews.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-header" class="top-header-menu"><li id="menu-item-192157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-192157"><a href="https://www.somagnews.com/about-us/">About Us</a></li>
<li id="menu-item-191798" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191798"><a href="https://www.somagnews.com/advertise/">Advertise</a></li>
<li id="menu-item-191797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191797"><a href="https://www.somagnews.com/advertisement-policy/">Advertisement Policy</a></li>
<li id="menu-item-191799" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191799"><a href="https://www.somagnews.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-191800" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191800"><a href="https://www.somagnews.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-191801" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191801"><a href="https://www.somagnews.com/imprint/">Imprint</a></li>
<li id="menu-item-191811" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191811"><a href="https://www.somagnews.com/contact/">Contact</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.somagnews.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/somagnews/" title="Facebook">
 <i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#5930373f36192a3634383e373c2e2a773a3634" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SoMagNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form id="loginForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<form id="forgotpassForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
</form>
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.somagnews.com/">
<img class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" alt="" width="281" />
<span class="td-visual-hidden">Somag News</span>
</a>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-header" href="https://www.somagnews.com/">
<img class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-12.png" alt="" width="141" height="49" />
</a>
<a class="td-header-logo td-sticky-header" href="https://www.somagnews.com/">
<img class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" alt="" width="281" height="97" />
</a>
</div>
<div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-37361"><a href="https://www.somagnews.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112095"><a href="https://www.somagnews.com/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-94731"><a href="https://www.somagnews.com/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60799"><a href="https://www.somagnews.com/celebrity/">Celebrity</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60798"><a href="https://www.somagnews.com/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-94730"><a href="https://www.somagnews.com/crypto/">Crypto</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60801"><a href="https://www.somagnews.com/science/">Science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60802"><a href="https://www.somagnews.com/sport/">Sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112093"><a href="https://www.somagnews.com/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112094"><a href="https://www.somagnews.com/travel/">Travel</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.somagnews.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in News" class="entry-crumb" href="https://www.somagnews.com/news/">News</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div align="center"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6529061836735688" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="9671093428" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<article id="post-204986" class="post-204986 post type-post status-publish format-standard has-post-thumbnail category-news" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">

<header class="td-post-title">
<h1 class="entry-title">Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.somagnews.com/author/kaitlyn-kubrick/">Kaitlyn Kubrick</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-04-25T18:55:21+00:00">April 25, 2022</time></span> <div class="td-post-comments"><a href="https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/#respond"><i class="td-icon-comments"></i>0</a></div>  </div>
</header>
</div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><a href="https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg" data-caption=""><img width="696" height="444" class="entry-thumb td-modal-image" src="https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8-696x444.jpg" srcset="https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8-696x444.jpg 696w, https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8-300x191.jpg 300w, https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8-768x490.jpg 768w, https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8-659x420.jpg 659w, https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg 825w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="elon musk" /></a></div>
<div class='code-block code-block-7' style='margin: 8px 8px 8px 0; float: left;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="9527945000"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong>Elon Musk&#8217;s</strong> offer to buy <strong>Twitter</strong> is gaining momentum and could be announced as early as Monday, according to media reports about the social network&#8217;s latest negotiations with the CEO of Tesla, who offered more than $40 billion to privatize the platform and promised to be more lenient when it comes to controlling users&#8217; speech.</p>
<p><strong>Twitter</strong> and <strong>Musk</strong> spoke on Sunday and in the early hours of Monday, The New York Times reported, less than two weeks after the billionaire first reported a 9 percent stake in the platform he uses to promote his interests, attack critics and speak out on social and economic issues. questions to his more than 83 million followers.</p>
<p>Last week, <strong>Musk</strong> announced that he had allocated $46.5 billion to buy <strong>Twitter,</strong> putting pressure on the company&#8217;s board of directors to agree on a deal. Musk did not comment on the talks, but on Monday plunged into the hype about them on Twitter, where some users promise to leave the platform if he takes over.</p>
<div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>
<div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="2414089350" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>&#8220;I hope that even my worst critics will remain on Twitter, because this is freedom of speech,&#8221; he wrote.</p>
<p>Musk has called himself an &#8220;absolutist of free speech,&#8221; but is also known for blocking or condemning other Twitter users who ask him questions or disagree with him.</p>
<p>In recent weeks, he has announced a number of proposed changes for the company, from easing content restrictions, such as the rules that suspended the account of former President Donald Trump, to ridding the platform of fake and automated accounts and abandoning its advertising. revenue model.</p>
<p>Twitter&#8217;s board is flexible in evaluating Musk&#8217;s proposal not only on finance, but also on the specifics of his business plan and how it might affect users, advertisers and employees &#8211; some of whom may leave, said Kevin Kaiser, a finance professor at the Wharton School in New York. University of Pennsylvania.</p>
<p>&#8220;It&#8217;s important for the board of directors whether they think it&#8217;s in the best interests of the company,&#8221; Kaiser said. &#8220;It can come from many, many factors.&#8221;</p>
<p>Kaiser said the board may decide Musk&#8217;s plan has &#8220;too many negative consequences,&#8221; but that would be difficult to do given how much Musk is offering to pay.</p>
<div class='code-block code-block-10' style='margin: 8px 0; clear: both;'>
<div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="2414089350" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>Asked during a recent TED talk if there are any restrictions on his notion of &#8220;freedom of speech,&#8221; Musk said that Twitter or any other forum &#8220;is obviously bound by the laws of the country in which they operate. Thus, it is obvious that there are some restrictions on freedom of speech.&#8221; in the US, and of course Twitter will have to comply with these rules.&#8221;</p>
<p>However, in addition to this, he said that he would be &#8220;very reluctant&#8221; to delete anything and in general would be cautious about permanent bans.</p>
<p>It won&#8217;t be perfect, Musk added, &#8220;but I think we want him to really have the feeling and reality that speech is as free as possible.&#8221;</p>
<p>Initially, Twitter took a measure against the takeover, known as a poison pill, which could make the takeover attempt excessively expensive. But the board decided to hold talks after Musk updated his offer last week to show that he had secured the funding, according to The Wall Street Journal, which first reported that negotiations were underway.</p>
<p>Musk&#8217;s competitor may not appear in the near future, fearing the Byzantine task of moderating content on the platform, which Musk promised to do less.</p>
<div class='code-block code-block-11' style='margin: 8px 0; clear: both;'>
<div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="2414089350" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>&#8220;Twitter&#8217;s board of directors couldn&#8217;t find a white knight, and with Musk&#8217;s financing details, the clock actually struck midnight for the board of directors, so negotiations began to conclude a deal,&#8221; said Dan Ives, who follows Twitter for Wedbush Securities.</p>
<div class='code-block code-block-8' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="9527945000"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
<footer>
 
<div class="td-post-source-tags">
  </div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
 </div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.somagnews.com%2Freports-musks-bid-to-buy-and-privatize-twitter-is-heating-up%2F" title="Facebook"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up&url=https%3A%2F%2Fwww.somagnews.com%2Freports-musks-bid-to-buy-and-privatize-twitter-is-heating-up%2F&via=somagnews" title="Twitter"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/&amp;media=https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg&description=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up" title="Pinterest"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up %0A%0A https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" title="WhatsApp"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/&title=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up" title="Linkedin"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/&title=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up" title="ReddIt"><div class="td-social-but-icon"><i class="td-icon-reddit"></i></div><div class="td-social-but-text">ReddIt</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#38074b4d5a525d5b4c056a5d48574a4c4b0218754d4b531e1b000a090f034b187a515c184c57187a4d411859565c18684a514e594c51425d186c4f514c4c5d4a18514b18705d594c51565f184d481e5a575c4105504c4c484b0217174f4f4f164b5755595f565d4f4b165b5755174a5d48574a4c4b15554d4b534b155a515c154c57155a4d411559565c15484a514e594c51425d154c4f514c4c5d4a15514b15505d594c51565f154d4817" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-tumblr" href="https://www.tumblr.com/share/link?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/&name=Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up" title="Tumblr"><div class="td-social-but-icon"><i class="td-icon-tumblr"></i></div><div class="td-social-but-text">Tumblr</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/&text=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up" title="Telegram"><div class="td-social-but-icon"><i class="td-icon-telegram"></i></div><div class="td-social-but-text">Telegram</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-stumbleupon" href="https://www.mix.com/add?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" title="Mix"><div class="td-social-but-icon"><i class="td-icon-stumbleupon"></i></div><div class="td-social-but-text">Mix</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" title="VK"><div class="td-social-but-icon"><i class="td-icon-vk"></i></div><div class="td-social-but-text">VK</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-digg" href="https://www.digg.com/submit?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" title="Digg"><div class="td-social-but-icon"><i class="td-icon-digg"></i></div><div class="td-social-but-text">Digg</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up%0D%0Ahttps://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" title="LINE"><div class="td-social-but-icon"><i class="td-icon-line"></i></div><div class="td-social-but-text">LINE</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-viber" href="viber://forward?text=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" title="Viber"><div class="td-social-but-icon"><i class="td-icon-viber"></i></div><div class="td-social-but-text">Viber</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-naver" href="https://share.naver.com/web/shareView.nhn?url=https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/&title=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up" title="Naver"><div class="td-social-but-icon"><i class="td-icon-naver"></i></div><div class="td-social-but-text">Naver</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-flipboard" href="https://share.flipboard.com/bookmarklet/popout?v=2&title=Reports%3A+Musk%E2%80%99s+Bid+to+Buy+and+Privatize+Twitter+is+Heating+up&url=https%3A%2F%2Fwww.somagnews.com%2Freports-musks-bid-to-buy-and-privatize-twitter-is-heating-up%2F" title="Flip"><div class="td-social-but-icon"><i class="td-icon-flipboard"></i></div><div class="td-social-but-text">Flip</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>  <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.somagnews.com/author/kaitlyn-kubrick/">Kaitlyn Kubrick</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Kaitlyn Kubrick"><meta itemprop="url" content="https://www.somagnews.com/author/kaitlyn-kubrick/"></span><meta itemprop="datePublished" content="2022-04-25T18:55:21+00:00"><meta itemprop="dateModified" content="2022-04-25T18:55:21+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png"></span><meta itemprop="name" content="Somag News"></span><meta itemprop="headline " content="Reports: Musk&#039;s Bid to Buy and Privatize Twitter is Heating up"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.somagnews.com/wp-content/uploads/2022/04/elon-musk-8.jpg"><meta itemprop="width" content="825"><meta itemprop="height" content="526"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_2 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_2","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":204986,"live_filter_cur_post_author":"3","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_related_posts";
block_tdi_2.post_count = "3";
block_tdi_2.found_posts = "4518";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "1506";
tdBlocksArray.push(block_tdi_2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2" href="#">RELATED ARTICLES</a><a id="tdi_4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.somagnews.com/elon-musks-gambit-is-to-buy-twitter-and-bring-his-own-version/" rel="bookmark" class="td-image-wrap " title="Elon Musk&#8217;s gambit is to buy Twitter and bring his own version&#8230;"><img width="218" height="150" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/04/er-218x150.jpg" srcset="https://www.somagnews.com/wp-content/uploads/2022/04/er-218x150.jpg 218w, https://www.somagnews.com/wp-content/uploads/2022/04/er-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Elon Musk&#8217;s gambit is to buy Twitter and bring his own version&#8230;" /></a></div> <a href="https://www.somagnews.com/news/" class="td-post-category">News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/elon-musks-gambit-is-to-buy-twitter-and-bring-his-own-version/" rel="bookmark" title="Elon Musk&#8217;s gambit is to buy Twitter and bring his own version&#8230;">Elon Musk&#8217;s gambit is to buy Twitter and bring his own version&#8230;</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.somagnews.com/julia-fox-as-lady-gaga-in-sky-high-platform-shoes/" rel="bookmark" class="td-image-wrap " title="Julia Fox as Lady Gaga in sky-high platform shoes"><img width="218" height="150" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/04/wer-218x150.jpg" srcset="https://www.somagnews.com/wp-content/uploads/2022/04/wer-218x150.jpg 218w, https://www.somagnews.com/wp-content/uploads/2022/04/wer-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Julia Fox as Lady Gaga in sky-high platform shoes" /></a></div> <a href="https://www.somagnews.com/news/" class="td-post-category">News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/julia-fox-as-lady-gaga-in-sky-high-platform-shoes/" rel="bookmark" title="Julia Fox as Lady Gaga in sky-high platform shoes">Julia Fox as Lady Gaga in sky-high platform shoes</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.somagnews.com/trumps-strange-prophecy-meghan-and-harry-will-get-divorced/" rel="bookmark" class="td-image-wrap " title="Trump&#8217;s strange prophecy: &#8220;Meghan and Harry will get divorced!&#8221;"><img width="218" height="150" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/04/trr-218x150.jpg" srcset="https://www.somagnews.com/wp-content/uploads/2022/04/trr-218x150.jpg 218w, https://www.somagnews.com/wp-content/uploads/2022/04/trr-100x70.jpg 100w" sizes="(max-width: 218px) 100vw, 218px" alt="" title="Trump&#8217;s strange prophecy: &#8220;Meghan and Harry will get divorced!&#8221;" /></a></div> <a href="https://www.somagnews.com/news/" class="td-post-category">News</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/trumps-strange-prophecy-meghan-and-harry-will-get-divorced/" rel="bookmark" title="Trump&#8217;s strange prophecy: &#8220;Meghan and Harry will get divorced!&#8221;">Trump&#8217;s strange prophecy: &#8220;Meghan and Harry will get divorced!&#8221;</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="block-5" class="td_block_template_1 widget block-5 widget_block"><div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6529061836735688" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="6302694057"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>
<aside id="recent-posts-3" class="td_block_template_1 widget recent-posts-3 widget_recent_entries">
<h4 class="block-title"><span>Recent Posts</span></h4>
<ul>
<li>
<a href="https://www.somagnews.com/elon-musks-gambit-is-to-buy-twitter-and-bring-his-own-version/">Elon Musk&#8217;s gambit is to buy Twitter and bring his own version&#8230;</a>
</li>
<li>
<a href="https://www.somagnews.com/reports-musks-bid-to-buy-and-privatize-twitter-is-heating-up/" aria-current="page">Reports: Musk&#8217;s Bid to Buy and Privatize Twitter is Heating up</a>
</li>
<li>
<a href="https://www.somagnews.com/johnny-depps-record-warns-of-a-bloodbath-if-disputes-escalate/">Johnny Depp&#8217;s Record Warns of a &#8220;bloodbath&#8221; if Disputes Escalate</a>
</li>
<li>
<a href="https://www.somagnews.com/amber-heards-source-comments-on-milani-cosmetics-courtroom/">Amber Heard&#8217;s Source Comments on Milani Cosmetics Courtroom</a>
</li>
<li>
<a href="https://www.somagnews.com/the-queue-for-the-trial-of-johnny-depp-and-amber-heard-has-gone-viral/">The queue for the trial of Johnny Depp and Amber Heard has gone viral</a>
</li>
<li>
<a href="https://www.somagnews.com/how-to-show-your-status-offline-in-league-of-legends/">How to show your status offline in League of Legends</a>
</li>
<li>
<a href="https://www.somagnews.com/julia-fox-as-lady-gaga-in-sky-high-platform-shoes/">Julia Fox as Lady Gaga in sky-high platform shoes</a>
</li>
<li>
<a href="https://www.somagnews.com/trumps-strange-prophecy-meghan-and-harry-will-get-divorced/">Trump&#8217;s strange prophecy: &#8220;Meghan and Harry will get divorced!&#8221;</a>
</li>
<li>
<a href="https://www.somagnews.com/trumps-decision-from-the-court-10-thousand-dollars-for-each-day/">Trump&#8217;s decision from the court: 10 thousand dollars for each day</a>
</li>
<li>
<a href="https://www.somagnews.com/skills-and-traits-of-the-turkish-agent-valorant-fade/">Skills and traits of the Turkish agent Valorant Fade</a>
</li>
</ul>
</aside><aside id="block-6" class="td_block_template_1 widget block-6 widget_block"><div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6529061836735688" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="6302694057"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="block-3" class="td_block_template_1 widget block-3 widget_block widget_text">
<p></p>
</aside> </div>
</div>
</div> 
</div> 
</div> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-14 ">
<div class="td-container td-footer-bottom-full">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.somagnews.com/"><img class="td-retina-data" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" alt="" title="" width="281" height="97" /></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Somag News is an online international news platform that founded in 2019 with a dynamic news team.Our news team includes reporters that has a speciality in different fields from each other.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#7a13141c153a0915171b1d141f0d0954191517"><span class="__cf_email__" data-cfemail="0a63646c654a7965676b6d646f7d7924696567">[email&#160;protected]</span></a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/somagnews/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#6b02050d042b1804060a0c050e1c1845080406" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SoMagNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></aside></div> </div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-192159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-192159"><a href="https://www.somagnews.com/about-us/">About Us</a></li>
<li id="menu-item-191816" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191816"><a href="https://www.somagnews.com/advertise/">Advertise</a></li>
<li id="menu-item-191815" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191815"><a href="https://www.somagnews.com/advertisement-policy/">Advertisement Policy</a></li>
<li id="menu-item-191817" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191817"><a href="https://www.somagnews.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-191818" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191818"><a href="https://www.somagnews.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-191819" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191819"><a href="https://www.somagnews.com/imprint/">Imprint</a></li>
<li id="menu-item-191820" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191820"><a href="https://www.somagnews.com/contact/">Contact</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.somagnews.com/cristiano-ronaldo-first-player-become-billionaire-according-forbes/" rel="bookmark" class="td-image-wrap " title="Cristiano Ronaldo is the first player to become a billionaire according to Forbes"><img width="100" height="70" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2020/04/18-4-e1586454766741-100x70.jpg" srcset="https://www.somagnews.com/wp-content/uploads/2020/04/18-4-e1586454766741-100x70.jpg 100w, https://www.somagnews.com/wp-content/uploads/2020/04/18-4-e1586454766741-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Cristiano Ronaldo is the first player to become a billionaire according to Forbes" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/cristiano-ronaldo-first-player-become-billionaire-according-forbes/" rel="bookmark" title="Cristiano Ronaldo is the first player to become a billionaire according to Forbes">Cristiano Ronaldo is the first player to become a billionaire according...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2020-04-09T17:53:07+00:00">April 9, 2020</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.somagnews.com/black-friday-500-brands-call-boycott/" rel="bookmark" class="td-image-wrap " title="Black Friday: Why more than 500 brands call for boycott"><img width="100" height="70" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2019/11/b-12-e1574511343318-100x70.jpg" srcset="https://www.somagnews.com/wp-content/uploads/2019/11/b-12-e1574511343318-100x70.jpg 100w, https://www.somagnews.com/wp-content/uploads/2019/11/b-12-e1574511343318-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px" alt="" title="Black Friday: Why more than 500 brands call for boycott" /></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/black-friday-500-brands-call-boycott/" rel="bookmark" title="Black Friday: Why more than 500 brands call for boycott">Black Friday: Why more than 500 brands call for boycott</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2019-11-23T12:15:55+00:00">November 23, 2019</time></span> </div>
</div>
</div>
</div>
</div>

<div class="td-container"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-ad-client="ca-pub-6529061836735688" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</div><script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.somagnews.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.5.6' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/td-cloud-library/assets/js/js_posts_autoload.min.js?ver=b2e02a383c117d2c27b181e37c1c9e0e' id='tdb_js_posts_autoload-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=11.4.3' id='td-site-min-js'></script>
<script type='text/javascript' id='tds_js_files_for_front-js-extra'>
/* <![CDATA[ */
var tds_js_globals = {"wpRestNonce":"868b07a2cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/td-subscription/assets/js/js_files_for_front.min.js?ver=1.3' id='tds_js_files_for_front-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/td-cloud-library/assets/js/js_files_for_front.min.js?ver=b2e02a383c117d2c27b181e37c1c9e0e' id='tdb_js_files_for_front-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>

<script>
    
</script>
</body>
</html>
