<!doctype html >
<!--[if IE 8]>    <html class="ie8" lang="en"> <![endif]-->
<!--[if IE 9]>    <html class="ie9" lang="en"> <![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" prefix="og: https://ogp.me/ns#"> <!--<![endif]-->
<head>
<title>Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any Of The Musicians&quot; ⋆ Somag News</title>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<link rel="pingback" href="https://www.somagnews.com/xmlrpc.php" />
<link rel="icon" type="image/png" href="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-15.png">

<meta name="description" content="Chuck D said that Public Enemy was &quot;pursued by the police more than any of the musicians.&quot;" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<link rel="canonical" href="https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any Of The Musicians&quot; ⋆ Somag News" />
<meta property="og:description" content="Chuck D said that Public Enemy was &quot;pursued by the police more than any of the musicians.&quot;" />
<meta property="og:url" content="https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" />
<meta property="og:site_name" content="Somag News" />
<meta property="article:publisher" content="https://www.facebook.com/somagnews/" />
<meta property="article:section" content="Entertainment" />
<meta property="og:image" content="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png" />
<meta property="og:image:secure_url" content="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png" />
<meta property="og:image:width" content="885" />
<meta property="og:image:height" content="579" />
<meta property="og:image:alt" content="Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More Than Any of The Musicians&#8221;" />
<meta property="og:image:type" content="image/png" />
<meta property="article:published_time" content="2022-12-30T16:18:01+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any Of The Musicians&quot; ⋆ Somag News" />
<meta name="twitter:description" content="Chuck D said that Public Enemy was &quot;pursued by the police more than any of the musicians.&quot;" />
<meta name="twitter:site" content="@somagnews" />
<meta name="twitter:creator" content="@somagnews" />
<meta name="twitter:image" content="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.somagnews.com/#organization","name":"Somag News","logo":{"@type":"ImageObject","@id":"https://www.somagnews.com/#logo","url":"https://www.somagnews.com/wp-content/uploads/2022/06/SOMAG-logo-final-05.png","contentUrl":"https://www.somagnews.com/wp-content/uploads/2022/06/SOMAG-logo-final-05.png","caption":"Somag News","inLanguage":"en-US","width":"141","height":"49"}},{"@type":"WebSite","@id":"https://www.somagnews.com/#website","url":"https://www.somagnews.com","name":"Somag News","publisher":{"@id":"https://www.somagnews.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png","url":"https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png","width":"885","height":"579","inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/#webpage","url":"https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/","name":"Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any Of The Musicians&quot; \u22c6 Somag News","datePublished":"2022-12-30T16:18:01+00:00","dateModified":"2022-12-30T16:18:01+00:00","isPartOf":{"@id":"https://www.somagnews.com/#website"},"primaryImageOfPage":{"@id":"https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png"},"inLanguage":"en-US"},{"@type":"Person","@id":"https://www.somagnews.com/author/adam-woods/","name":"Adam Woods","url":"https://www.somagnews.com/author/adam-woods/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/59ee3b2233dc1951468dadfc5febdedd?s=96&amp;d=blank&amp;r=g","url":"https://secure.gravatar.com/avatar/59ee3b2233dc1951468dadfc5febdedd?s=96&amp;d=blank&amp;r=g","caption":"Adam Woods","inLanguage":"en-US"},"worksFor":{"@id":"https://www.somagnews.com/#organization"}},{"@type":"NewsArticle","headline":"Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any Of The Musicians&quot; \u22c6","datePublished":"2022-12-30T16:18:01+00:00","dateModified":"2022-12-30T16:18:01+00:00","author":{"@id":"https://www.somagnews.com/author/adam-woods/"},"publisher":{"@id":"https://www.somagnews.com/#organization"},"description":"Chuck D said that Public Enemy was &quot;pursued by the police more than any of the musicians.&quot;","copyrightYear":"2022","copyrightHolder":{"@id":"https://www.somagnews.com/#organization"},"name":"Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any Of The Musicians&quot; \u22c6","@id":"https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/#richSnippet","isPartOf":{"@id":"https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/#webpage"},"image":{"@id":"https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Somag News &raquo; Feed" href="https://www.somagnews.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Somag News &raquo; Comments Feed" href="https://www.somagnews.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Somag News &raquo; Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More Than Any of The Musicians&#8221; Comments Feed" href="https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.somagnews.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=afb24994d1a83bf9201f947f3160754b"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(p&&p.fillText)switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.somagnews.com/wp-includes/css/dist/block-library/style.min.css?ver=afb24994d1a83bf9201f947f3160754b' type='text/css' media='all' />
<link rel='stylesheet' id='classic-theme-styles-css' href='https://www.somagnews.com/wp-includes/css/classic-themes.min.css?ver=1' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.somagnews.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-newsletter-css' href='https://www.somagnews.com/wp-content/plugins/td-newsletter/style.css?ver=12.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='td-plugin-multi-purpose-css' href='https://www.somagnews.com/wp-content/plugins/td-composer/td-multi-purpose/style.css?ver=e815948e5c9ec5801de67b92a1d5a59fxx' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-style-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A400%2C600%2C700%7CRoboto%3A400%2C500%2C700&#038;display=swap&#038;ver=12.1.1' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css' href='https://www.somagnews.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='tds-front-css' href='https://www.somagnews.com/wp-content/plugins/td-subscription/assets/css/tds-front.css?ver=1.3.3' type='text/css' media='all' />
<link rel='stylesheet' id='td-theme-css' href='https://www.somagnews.com/wp-content/themes/Newspaper/style.css?ver=12.1.1' type='text/css' media='all' />
<style id='td-theme-inline-css' type='text/css'>
    
        @media (max-width: 767px) {
            .td-header-desktop-wrap {
                display: none;
            }
        }
        @media (min-width: 767px) {
            .td-header-mobile-wrap {
                display: none;
            }
        }
    
	
</style>
<link rel='stylesheet' id='td-legacy-framework-front-style-css' href='https://www.somagnews.com/wp-content/plugins/td-composer/legacy/Newspaper/assets/css/td_legacy_main.css?ver=e815948e5c9ec5801de67b92a1d5a59fxx' type='text/css' media='all' />
<link rel='stylesheet' id='td-standard-pack-framework-front-style-css' href='https://www.somagnews.com/wp-content/plugins/td-standard-pack/Newspaper/assets/css/td_standard_pack_main.css?ver=48767bfdc5698c9103b4ef9b700012fd' type='text/css' media='all' />
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://www.somagnews.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.somagnews.com/wp-json/wp/v2/posts/367220" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.somagnews.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.somagnews.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.somagnews.com/?p=367220' />
<link rel="alternate" type="application/json+oembed" href="https://www.somagnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somagnews.com%2Fchuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.somagnews.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.somagnews.com%2Fchuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians%2F&#038;format=xml" />
<!--[if lt IE 9]><script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.js"></script><![endif]-->
<script>
				window.tdwGlobal = {"adminUrl":"https:\/\/www.somagnews.com\/wp-admin\/","wpRestNonce":"8d581024cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
			</script>
<script>
        window.tdaGlobal = {"adminUrl":"https:\/\/www.somagnews.com\/wp-admin\/","wpRestNonce":"8d581024cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/","postId":367220};
    </script>

<script>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</script>

<style>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</style>

<script async src="https://www.googletagmanager.com/gtag/js?id=UA-147729238-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-147729238-1');
</script>
<script type="application/ld+json">
    {
        "@context": "http://schema.org",
        "@type": "BreadcrumbList",
        "itemListElement": [
            {
                "@type": "ListItem",
                "position": 1,
                "item": {
                    "@type": "WebSite",
                    "@id": "https://www.somagnews.com/",
                    "name": "Home"
                }
            },
            {
                "@type": "ListItem",
                "position": 2,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somagnews.com/entertainment/",
                    "name": "Entertainment"
                }
            }
            ,{
                "@type": "ListItem",
                "position": 3,
                    "item": {
                    "@type": "WebPage",
                    "@id": "https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/",
                    "name": "Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More..."                                
                }
            }    
        ]
    }
</script>

<style>
    
</style>
<style id="tdw-css-placeholder"></style></head>
<body data-rsssl=1 class="post-template-default single single-post postid-367220 single-format-standard td-standard-pack chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians global-block-template-1 td-full-layout" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="td-scroll-up  td-hide-scroll-up-on-mob" style="display:none;"><i class="td-icon-menu-up"></i></div>
<div class="td-menu-background" style="visibility:hidden"></div>
<div id="td-mobile-nav" style="visibility:hidden">
<div class="td-mobile-container">

<div class="td-menu-socials-wrap">

<div class="td-menu-socials">
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/somagnews/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#aac3c4ccc5ead9c5c7cbcdc4cfddd984c9c5c7" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SoMagNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div>

<div class="td-mobile-close">
<a href="#" aria-label="Close"><i class="td-icon-close-mobile"></i></a>
</div>
</div>


<div class="td-mobile-content">
<div class="menu-top-menu-container"><ul id="menu-top-menu" class="td-mobile-main-menu"><li id="menu-item-37361" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first menu-item-37361"><a href="https://www.somagnews.com/">Home</a></li>
<li id="menu-item-112095" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112095"><a href="https://www.somagnews.com/world/">World</a></li>
<li id="menu-item-94731" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94731"><a href="https://www.somagnews.com/entertainment/">Entertainment</a></li>
<li id="menu-item-60799" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60799"><a href="https://www.somagnews.com/celebrity/">Celebrity</a></li>
<li id="menu-item-60798" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60798"><a href="https://www.somagnews.com/tech/">Tech</a></li>
<li id="menu-item-94730" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94730"><a href="https://www.somagnews.com/crypto/">Crypto</a></li>
<li id="menu-item-60801" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60801"><a href="https://www.somagnews.com/science/">Science</a></li>
<li id="menu-item-60802" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-60802"><a href="https://www.somagnews.com/sport/">Sport</a></li>
<li id="menu-item-112093" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112093"><a href="https://www.somagnews.com/health/">Health</a></li>
<li id="menu-item-112094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-112094"><a href="https://www.somagnews.com/travel/">Travel</a></li>
</ul></div> </div>
</div>

</div> <div class="td-search-background" style="visibility:hidden"></div>
<div class="td-search-wrap-mob" style="visibility:hidden">
<div class="td-drop-down-search">
<form method="get" class="td-search-form" action="https://www.somagnews.com/">

<div class="td-search-close">
<a href="#"><i class="td-icon-close-mobile"></i></a>
</div>
<div role="search" class="td-search-input">
<span>Search</span>
<input id="td-header-search-mob" type="text" value="" name="s" autocomplete="off" />
</div>
</form>
<div id="td-aj-search-mob" class="td-ajax-search-flex"></div>
</div>
</div>
<div id="td-outer-wrap" class="td-theme-wrap">
<div class="tdc-header-wrap ">

<div class="td-header-wrap td-header-style-10 ">
<div class="td-header-top-menu-full td-container-wrap ">
<div class="td-container td-header-row td-header-top-menu">
<div class="top-bar-style-1">
<div class="td-header-sp-top-menu">
<div class="menu-top-container"><ul id="menu-top-header" class="top-header-menu"><li id="menu-item-192157" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-192157"><a href="https://www.somagnews.com/about-us/">About Us</a></li>
<li id="menu-item-191798" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191798"><a href="https://www.somagnews.com/advertise/">Advertise</a></li>
<li id="menu-item-191797" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191797"><a href="https://www.somagnews.com/advertisement-policy/">Advertisement Policy</a></li>
<li id="menu-item-191799" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191799"><a href="https://www.somagnews.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-191800" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191800"><a href="https://www.somagnews.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-191801" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191801"><a href="https://www.somagnews.com/imprint/">Imprint</a></li>
<li id="menu-item-191811" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191811"><a href="https://www.somagnews.com/contact/">Contact</a></li>
</ul></div></div>
<div class="td-header-sp-top-widget">
<div class="td-search-btns-wrap">
<a id="td-header-search-button" href="#" role="button" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
<div class="td-drop-down-search" aria-labelledby="td-header-search-button">
<form method="get" class="td-search-form" action="https://www.somagnews.com/">
<div role="search" class="td-head-form-search-wrap">
<input id="td-header-search" type="text" value="" name="s" autocomplete="off" /><input class="wpb_button wpb_btn-inverse btn" type="submit" id="td-header-search-top" value="Search" />
</div>
</form>
<div id="td-aj-search"></div>
</div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/somagnews/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#036a6d656c43706c6e62646d6674702d606c6e" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SoMagNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span> </div> </div>

<div id="login-form" class="white-popup-block mfp-hide mfp-with-anim td-login-modal-wrap">
<div class="td-login-wrap">
<a href="#" aria-label="Back" class="td-back-button"><i class="td-icon-modal-back"></i></a>
<div id="td-login-div" class="td-login-form-div td-display-block">
<div class="td-login-panel-title">Sign in</div>
<div class="td-login-panel-descr">Welcome! Log into your account</div>
<div class="td_display_err"></div>
<form id="loginForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" autocomplete="username" type="text" name="login_email" id="login_email" value="" required><label for="login_email">your username</label></div>
<div class="td-login-inputs"><input class="td-login-input" autocomplete="current-password" type="password" name="login_pass" id="login_pass" value="" required><label for="login_pass">your password</label></div>
<input type="button" name="login_button" id="login_button" class="wpb_button btn td-login-button" value="Login">
</form>
<div class="td-login-info-text"><a href="#" id="forgot-pass-link">Forgot your password? Get help</a></div>
</div>
<div id="td-forgot-pass-div" class="td-login-form-div td-display-none">
<div class="td-login-panel-title">Password recovery</div>
<div class="td-login-panel-descr">Recover your password</div>
<div class="td_display_err"></div>
<form id="forgotpassForm" action="#" method="post">
<div class="td-login-inputs"><input class="td-login-input" type="text" name="forgot_email" id="forgot_email" value="" required><label for="forgot_email">your email</label></div>
<input type="button" name="forgot_button" id="forgot_button" class="wpb_button btn td-login-button" value="Send My Password">
</form>
<div class="td-login-info-text">A password will be e-mailed to you.</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-banner-wrap-full td-logo-wrap-full td-logo-mobile-loaded td-container-wrap ">
<div class="td-header-sp-logo">
<a class="td-main-logo" href="https://www.somagnews.com/">
<img data-lazyloaded="1" src="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" data-src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" alt="" width="281" /><noscript><img class="td-retina-data"  data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" alt="" width="281"/></noscript>
<span class="td-visual-hidden">Somag News</span>
</a>
</div>
</div>
<div class="td-header-menu-wrap-full td-container-wrap ">
<div class="td-header-menu-wrap td-header-gradient td-header-menu-no-search">
<div class="td-container td-header-row td-header-main-menu">
<div id="td-header-menu" role="navigation">
<div id="td-top-mobile-toggle"><a href="#"><i class="td-icon-font td-icon-mobile"></i></a></div>
<div class="td-main-menu-logo td-logo-in-header">
<a class="td-mobile-logo td-sticky-header" href="https://www.somagnews.com/">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxNDEiIGhlaWdodD0iNDkiIHZpZXdCb3g9IjAgMCAxNDEgNDkiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNmZmZmZmYiLz48L3N2Zz4=" class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" data-src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-12.png" alt="" width="141" height="49" /><noscript><img class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-12.png" alt="" width="141" height="49"/></noscript>
</a>
<a class="td-header-logo td-sticky-header" href="https://www.somagnews.com/">
<img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyODEiIGhlaWdodD0iOTciIHZpZXdCb3g9IjAgMCAyODEgOTciPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNmZmZmZmYiLz48L3N2Zz4=" class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" data-src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" alt="" width="281" height="97" /><noscript><img class="td-retina-data" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" alt="" width="281" height="97"/></noscript>
</a>
</div>
<div class="menu-top-menu-container"><ul id="menu-top-menu-1" class="sf-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-first td-menu-item td-normal-menu menu-item-37361"><a href="https://www.somagnews.com/">Home</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112095"><a href="https://www.somagnews.com/world/">World</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent td-menu-item td-normal-menu menu-item-94731"><a href="https://www.somagnews.com/entertainment/">Entertainment</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60799"><a href="https://www.somagnews.com/celebrity/">Celebrity</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60798"><a href="https://www.somagnews.com/tech/">Tech</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-94730"><a href="https://www.somagnews.com/crypto/">Crypto</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60801"><a href="https://www.somagnews.com/science/">Science</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-60802"><a href="https://www.somagnews.com/sport/">Sport</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112093"><a href="https://www.somagnews.com/health/">Health</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category td-menu-item td-normal-menu menu-item-112094"><a href="https://www.somagnews.com/travel/">Travel</a></li>
</ul></div></div>
<div class="td-search-wrapper">
<div id="td-top-search">

<div class="header-search-wrap">
<div class="dropdown header-search">
<a id="td-header-search-button-mob" href="#" class="dropdown-toggle " data-toggle="dropdown"><i class="td-icon-search"></i></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-main-content-wrap td-container-wrap">
<div class="td-container td-post-template-default ">
<div class="td-crumb-container"><div class="entry-crumbs"><span><a title="" class="entry-crumb" href="https://www.somagnews.com/">Home</a></span> <i class="td-icon-right td-bread-sep"></i> <span><a title="View all posts in Entertainment" class="entry-crumb" href="https://www.somagnews.com/entertainment/">Entertainment</a></span> <i class="td-icon-right td-bread-sep td-bred-no-url-last"></i> <span class="td-bred-no-url-last">Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More...</span></div></div>
<div class="td-pb-row">
<div class="td-pb-span8 td-main-content" role="main">
<div class="td-ss-main-content">
<div class='code-block code-block-1' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<div align="center"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6529061836735688" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="9671093428" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<article id="post-367220" class="post-367220 post type-post status-publish format-standard has-post-thumbnail hentry category-entertainment" itemscope itemtype="https://schema.org/Article">
<div class="td-post-header">

<header class="td-post-title">
<h1 class="entry-title">Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More Than Any of The Musicians&#8221;</h1>
<div class="td-module-meta-info">
<div class="td-post-author-name"><div class="td-author-by">By</div> <a href="https://www.somagnews.com/author/adam-woods/">Adam Woods</a><div class="td-author-line"> - </div> </div> <span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-12-30T16:18:01+00:00">December 30, 2022</time></span> <div class="td-post-comments"><a href="https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/#respond"><i class="td-icon-comments"></i>0</a></div>  </div>
</header>
</div>
<div class="td-post-content tagdiv-type">
<div class="td-post-featured-image"><a href="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png" data-caption=""><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSI2OTYiIGhlaWdodD0iNDU1IiB2aWV3Qm94PSIwIDAgNjk2IDQ1NSI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZmZmZmZiIvPjwvc3ZnPg==" width="696" height="455" class="entry-thumb td-modal-image" data-src="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-696x455.png" data-srcset="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-696x455.png 696w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-300x196.png 300w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-768x502.png 768w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-642x420.png 642w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-741x486.png 741w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png 885w" data-sizes="(max-width: 696px) 100vw, 696px" alt="" title="CHUCK" /><noscript><img width="696" height="455" class="entry-thumb td-modal-image" src="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-696x455.png" srcset="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-696x455.png 696w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-300x196.png 300w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-768x502.png 768w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-642x420.png 642w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK-741x486.png 741w, https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png 885w" sizes="(max-width: 696px) 100vw, 696px" alt="" title="CHUCK"/></noscript></a></div>
<div class='code-block code-block-7' style='margin: 8px 8px 8px 0; float: left;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="9527945000"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
<p><strong>Chuck</strong> <strong>D</strong> said that Public Enemy was &#8220;pursued by the police more than any of the musicians.&#8221;</p>
<p>The politically motivated hip-hop group became famous in the late 1980s thanks to such hits as &#8220;Fight The Power&#8221; and &#8220;It Takes A Nation Of Millions To Hold Us Back&#8221; together with the NWA, who also periodically clashed with law enforcement agencies because of their own interests. uncompromising lyrics about police brutality and racism.</p>
<p>Now, in an interview with The Guardian, the rapper has said that, in his opinion, his band has faced the worst negative reaction.</p>
<div class='code-block code-block-9' style='margin: 8px 0; clear: both;'>
<div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="2414089350" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>&#8220;I&#8217;m not aware of bullying, but yes, probably more than anyone in music,&#8221; he said when asked how much &#8220;police harassment and FBI intimidation&#8221; <strong>Public Enemy</strong> has received.</p>
<p><iframe title="Public Enemy - Fight The Power (Official Music Video)" width="696" height="392" src="https://www.youtube.com/embed/mmo3HFa2vjg?feature=oembed" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen></iframe></p>
<p>&#8220;It&#8217;s not something that can be annoying. That&#8217;s what it is. The most I could do was write songs about it,&#8221; he added. &#8220;About <strong>Public Enemy&#8217;s</strong> first album &#8220;Yo! Bum Rush The Show&#8221;, we said that the responsibility lies with the government. Governments in the plural, because governments like to divide people, and music likes to unite people.&#8221;</p>
<p>When asked why hip-hop interacts so fleetingly with politics today, <strong>Chuck</strong> <strong>D</strong> replied: &#8220;Because the revolution cannot be sold. It cannot be sold the way other music is sold; it must be given to people. We had the blessing of the right age, the right place, the right time. I was the person who had the right thing: black music in New York.&#8221;</p>
<p>Meanwhile, the rapper recently sold a huge chunk of his back catalogue to his longtime publisher.</p>
<p>Reach Music acquired 100% of the rapper&#8217;s royalties, as well as half of his copyright as a publisher.</p>
<div class='code-block code-block-10' style='margin: 8px 0; clear: both;'>
<div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-6529061836735688" data-ad-slot="2414089350" data-ad-format="auto" data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div>
<p>The sale did not cover all <strong>Chuck</strong> <strong>D</strong> products, but included more than 300 songs, including the most significant work of Public Enemy, released between 1987 and 2012.</p>
<div class='code-block code-block-8' style='margin: 8px auto; text-align: center; display: block; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="9527945000"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>

</div>
<footer>
 
<div class="td-post-source-tags">
  </div>
<div class="td-post-sharing-bottom"><div id="td_social_sharing_article_bottom" class="td-post-sharing td-ps-bg td-ps-notext td-post-sharing-style1 ">
<style>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</style>
<div class="td-post-sharing-visible"><div class="td-social-sharing-button td-social-sharing-button-js td-social-handler td-social-share-text">
<div class="td-social-but-icon"><i class="td-icon-share"></i></div>
<div class="td-social-but-text">Share</div>
</div><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-facebook" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.somagnews.com%2Fchuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians%2F" title="Facebook"><div class="td-social-but-icon"><i class="td-icon-facebook"></i></div><div class="td-social-but-text">Facebook</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-twitter" href="https://twitter.com/intent/tweet?text=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D&url=https%3A%2F%2Fwww.somagnews.com%2Fchuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians%2F&via=somagnews" title="Twitter"><div class="td-social-but-icon"><i class="td-icon-twitter"></i></div><div class="td-social-but-text">Twitter</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-pinterest" href="https://pinterest.com/pin/create/button/?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/&amp;media=https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png&description=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D" title="Pinterest"><div class="td-social-but-icon"><i class="td-icon-pinterest"></i></div><div class="td-social-but-text">Pinterest</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-whatsapp" href="https://api.whatsapp.com/send?text=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D %0A%0A https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" title="WhatsApp"><div class="td-social-but-icon"><i class="td-icon-whatsapp"></i></div><div class="td-social-but-text">WhatsApp</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/&title=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D" title="Linkedin"><div class="td-social-but-icon"><i class="td-icon-linkedin"></i></div><div class="td-social-but-text">Linkedin</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-reddit" href="https://reddit.com/submit?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/&title=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D" title="ReddIt"><div class="td-social-but-icon"><i class="td-icon-reddit"></i></div><div class="td-social-but-text">ReddIt</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-mail" href="/cdn-cgi/l/email-protection#f5ca8680979f909681c8b69d80969ed5b1d5a6948c86cfd5d3d6cdc7c7c5cea58097999c96d5b09b90988cd5bd948390d5b790909bd5bd94879486869091d5b78cd5a19d90d5a59a999c9690d5b89a8790d5a19d949bd5b49b8cd59a93d5a19d90d5b880869c969c949b86d3d6cdc7c7c4ced3979a918cc89d81818586cfdada828282db869a9894929b908286db969a98da969d80969ed891d886948c86d8858097999c96d8909b90988cd89d948390d89790909bd89d94879486869091d8978cd8819d90d8859a999c9690d8989a8790d8819d949bd8949b8cd89a93d8819d90d89880869c969c949b86da" title="Email"><div class="td-social-but-icon"><i class="td-icon-mail"></i></div><div class="td-social-but-text">Email</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-tumblr" href="https://www.tumblr.com/share/link?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/&name=Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More Than Any of The Musicians&#8221;" title="Tumblr"><div class="td-social-but-icon"><i class="td-icon-tumblr"></i></div><div class="td-social-but-text">Tumblr</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-telegram" href="https://telegram.me/share/url?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/&text=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D" title="Telegram"><div class="td-social-but-icon"><i class="td-icon-telegram"></i></div><div class="td-social-but-text">Telegram</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-stumbleupon" href="https://www.mix.com/add?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" title="Mix"><div class="td-social-but-icon"><i class="td-icon-stumbleupon"></i></div><div class="td-social-but-text">Mix</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-vk" href="https://vk.com/share.php?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" title="VK"><div class="td-social-but-icon"><i class="td-icon-vk"></i></div><div class="td-social-but-text">VK</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-digg" href="https://www.digg.com/submit?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" title="Digg"><div class="td-social-but-icon"><i class="td-icon-digg"></i></div><div class="td-social-but-text">Digg</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-line" href="https://line.me/R/msg/text/?Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D%0D%0Ahttps://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" title="LINE"><div class="td-social-but-icon"><i class="td-icon-line"></i></div><div class="td-social-but-text">LINE</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-viber" href="viber://forward?text=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" title="Viber"><div class="td-social-but-icon"><i class="td-icon-viber"></i></div><div class="td-social-but-text">Viber</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-naver" href="https://share.naver.com/web/shareView.nhn?url=https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/&title=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D" title="Naver"><div class="td-social-but-icon"><i class="td-icon-naver"></i></div><div class="td-social-but-text">Naver</div></a><a class="td-social-sharing-button td-social-sharing-button-js td-social-network td-social-flipboard" href="https://share.flipboard.com/bookmarklet/popout?v=2&title=Chuck+D+Says%3A+%E2%80%9CPublic+Enemy+Have+Been+Harassed+By+The+Police+More+Than+Any+of+The+Musicians%E2%80%9D&url=https%3A%2F%2Fwww.somagnews.com%2Fchuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians%2F" title="Flip"><div class="td-social-but-icon"><i class="td-icon-flipboard"></i></div><div class="td-social-but-text">Flip</div></a></div><div class="td-social-sharing-hidden"><ul class="td-pulldown-filter-list"></ul><a class="td-social-sharing-button td-social-handler td-social-expand-tabs" href="#" data-block-uid="td_social_sharing_article_bottom" title="More">
<div class="td-social-but-icon"><i class="td-icon-plus td-social-expand-tabs-icon"></i></div>
</a></div></div></div>  <div class="td-author-name vcard author" style="display: none"><span class="fn"><a href="https://www.somagnews.com/author/adam-woods/">Adam Woods</a></span></div> <span class="td-page-meta" itemprop="author" itemscope itemtype="https://schema.org/Person"><meta itemprop="name" content="Adam Woods"><meta itemprop="url" content="https://www.somagnews.com/author/adam-woods/"></span><meta itemprop="datePublished" content="2022-12-30T16:18:01+00:00"><meta itemprop="dateModified" content="2022-12-30T16:18:01+00:00"><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" /><span class="td-page-meta" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><span class="td-page-meta" itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png"></span><meta itemprop="name" content="Somag News"></span><meta itemprop="headline " content="Chuck D Says: &quot;Public Enemy Have Been Harassed By The Police More Than Any of The Musicians&quot;"><span class="td-page-meta" itemprop="image" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://www.somagnews.com/wp-content/uploads/2022/12/CHUCK.png"><meta itemprop="width" content="885"><meta itemprop="height" content="579"></span> </footer>
</article> 
<div class="td_block_wrap td_block_related_posts tdi_2 td_with_ajax_pagination td-pb-border-top td_block_template_1" data-td-block-uid="tdi_2"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>var block_tdi_2 = new tdBlock();
block_tdi_2.id = "tdi_2";
block_tdi_2.atts = '{"limit":3,"ajax_pagination":"next_prev","live_filter":"cur_post_same_categories","td_ajax_filter_type":"td_custom_related","class":"tdi_2","td_column_number":3,"block_type":"td_block_related_posts","live_filter_cur_post_id":367220,"live_filter_cur_post_author":"15","block_template_id":"","header_color":"","ajax_pagination_infinite_stop":"","offset":"","td_ajax_preloading":"","td_filter_default_txt":"","td_ajax_filter_ids":"","el_class":"","color_preset":"","ajax_pagination_next_prev_swipe":"","border_top":"","css":"","tdc_css":"","tdc_css_class":"tdi_2","tdc_css_class_style":"tdi_2_rand_style"}';
block_tdi_2.td_column_number = "3";
block_tdi_2.block_type = "td_block_related_posts";
block_tdi_2.post_count = "3";
block_tdi_2.found_posts = "33741";
block_tdi_2.header_color = "";
block_tdi_2.ajax_pagination_infinite_stop = "";
block_tdi_2.max_num_pages = "11247";
tdBlocksArray.push(block_tdi_2);
</script><h4 class="td-related-title td-block-title"><a id="tdi_3" class="td-related-left td-cur-simple-item" data-td_filter_value="" data-td_block_id="tdi_2" href="#">RELATED ARTICLES</a><a id="tdi_4" class="td-related-right" data-td_filter_value="td_related_more_from_author" data-td_block_id="tdi_2" href="#">MORE FROM AUTHOR</a></h4><div id=tdi_2 class="td_block_inner">
<div class="td-related-row">
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.somagnews.com/coach-max-waldo-has-parted-ways-with-cloud9/" rel="bookmark" class="td-image-wrap " title="Coach Max Waldo Has Parted Ways With Cloud9"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMTgiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMjE4IDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZmZmZmZiIvPjwvc3ZnPg==" width="218" height="150" class="entry-thumb" data-src="https://www.somagnews.com/wp-content/uploads/2022/12/MAX-218x150.png" data-srcset="https://www.somagnews.com/wp-content/uploads/2022/12/MAX-218x150.png 218w, https://www.somagnews.com/wp-content/uploads/2022/12/MAX-100x70.png 100w" data-sizes="(max-width: 218px) 100vw, 218px" alt="" title="Coach Max Waldo Has Parted Ways With Cloud9" /><noscript><img width="218" height="150" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/12/MAX-218x150.png"  srcset="https://www.somagnews.com/wp-content/uploads/2022/12/MAX-218x150.png 218w, https://www.somagnews.com/wp-content/uploads/2022/12/MAX-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Coach Max Waldo Has Parted Ways With Cloud9" /></noscript></a></div> <a href="https://www.somagnews.com/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/coach-max-waldo-has-parted-ways-with-cloud9/" rel="bookmark" title="Coach Max Waldo Has Parted Ways With Cloud9">Coach Max Waldo Has Parted Ways With Cloud9</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.somagnews.com/liiv-sandbox-signs-contract-with-lcks-first-female-player-dangmoo/" rel="bookmark" class="td-image-wrap " title="Liiv SANDBOX Signs Contract With LCK&#8217;s First Female Player, DangMoo"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMTgiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMjE4IDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZmZmZmZiIvPjwvc3ZnPg==" width="218" height="150" class="entry-thumb" data-src="https://www.somagnews.com/wp-content/uploads/2022/12/LIVV-1-218x150.png" data-srcset="https://www.somagnews.com/wp-content/uploads/2022/12/LIVV-1-218x150.png 218w, https://www.somagnews.com/wp-content/uploads/2022/12/LIVV-1-100x70.png 100w" data-sizes="(max-width: 218px) 100vw, 218px" alt="" title="Liiv SANDBOX Signs Contract With LCK&#8217;s First Female Player, DangMoo" /><noscript><img width="218" height="150" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/12/LIVV-1-218x150.png"  srcset="https://www.somagnews.com/wp-content/uploads/2022/12/LIVV-1-218x150.png 218w, https://www.somagnews.com/wp-content/uploads/2022/12/LIVV-1-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="Liiv SANDBOX Signs Contract With LCK&#8217;s First Female Player, DangMoo" /></noscript></a></div> <a href="https://www.somagnews.com/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/liiv-sandbox-signs-contract-with-lcks-first-female-player-dangmoo/" rel="bookmark" title="Liiv SANDBOX Signs Contract With LCK&#8217;s First Female Player, DangMoo">Liiv SANDBOX Signs Contract With LCK&#8217;s First Female Player, DangMoo</a></h3> </div>
</div>
</div> 
<div class="td-related-span4">
<div class="td_module_related_posts td-animation-stack td_mod_related_posts">
<div class="td-module-image">
<div class="td-module-thumb"><a href="https://www.somagnews.com/v-from-bts-shows-off-her-riding-skills-behind-the-scenes-of-me-myself-and-v-veautiful-days/" rel="bookmark" class="td-image-wrap " title="V From BTS Shows Off Her Riding Skills Behind The Scenes of &#8220;Me, Myself, and V&#8221; &#8220;Veautiful Days&#8221;."><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyMTgiIGhlaWdodD0iMTUwIiB2aWV3Qm94PSIwIDAgMjE4IDE1MCI+PHJlY3Qgd2lkdGg9IjEwMCUiIGhlaWdodD0iMTAwJSIgZmlsbD0iI2ZmZmZmZiIvPjwvc3ZnPg==" width="218" height="150" class="entry-thumb" data-src="https://www.somagnews.com/wp-content/uploads/2022/12/BTS-1-218x150.png" data-srcset="https://www.somagnews.com/wp-content/uploads/2022/12/BTS-1-218x150.png 218w, https://www.somagnews.com/wp-content/uploads/2022/12/BTS-1-100x70.png 100w" data-sizes="(max-width: 218px) 100vw, 218px" alt="" title="V From BTS Shows Off Her Riding Skills Behind The Scenes of &#8220;Me, Myself, and V&#8221; &#8220;Veautiful Days&#8221;." /><noscript><img width="218" height="150" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/12/BTS-1-218x150.png"  srcset="https://www.somagnews.com/wp-content/uploads/2022/12/BTS-1-218x150.png 218w, https://www.somagnews.com/wp-content/uploads/2022/12/BTS-1-100x70.png 100w" sizes="(max-width: 218px) 100vw, 218px"  alt="" title="V From BTS Shows Off Her Riding Skills Behind The Scenes of &#8220;Me, Myself, and V&#8221; &#8220;Veautiful Days&#8221;." /></noscript></a></div> <a href="https://www.somagnews.com/entertainment/" class="td-post-category">Entertainment</a> </div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/v-from-bts-shows-off-her-riding-skills-behind-the-scenes-of-me-myself-and-v-veautiful-days/" rel="bookmark" title="V From BTS Shows Off Her Riding Skills Behind The Scenes of &#8220;Me, Myself, and V&#8221; &#8220;Veautiful Days&#8221;.">V From BTS Shows Off Her Riding Skills Behind The Scenes of &#8220;Me, Myself, and V&#8221; &#8220;Veautiful Days&#8221;.</a></h3> </div>
</div>
</div> </div></div><div class="td-next-prev-wrap"><a href="#" class="td-ajax-prev-page ajax-page-disabled" aria-label="prev-page" id="prev-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-left"></i></a><a href="#" class="td-ajax-next-page" aria-label="next-page" id="next-page-tdi_2" data-td_block_id="tdi_2"><i class="td-next-prev-icon td-icon-font td-icon-menu-right"></i></a></div></div> 
<div class="comments" id="comments">
<div id="respond" class="comment-respond">
<h3 id="reply-title" class="comment-reply-title">LEAVE A REPLY <small><a rel="nofollow" id="cancel-comment-reply-link" href="/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.somagnews.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><div class="clearfix"></div>
<div class="comment-form-input-wrap td-form-comment">
<textarea placeholder="Comment:" id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea>
<div class="td-warning-comment">Please enter your comment!</div>
</div><div class="comment-form-input-wrap td-form-author">
<input class="" id="author" name="author" placeholder="Name:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-author">Please enter your name here</div>
</div>
<div class="comment-form-input-wrap td-form-email">
<input class="" id="email" name="email" placeholder="Email:*" type="text" value="" size="30" aria-required='true' />
<div class="td-warning-email-error">You have entered an incorrect email address!</div>
<div class="td-warning-email">Please enter your email address here</div>
</div>
<div class="comment-form-input-wrap td-form-url">
<input class="" id="url" name="url" placeholder="Website:" type="text" value="" size="30" />
</div>
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='367220' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="8ca7851464" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="206" /><script>document.getElementById( "ak_js_1" ).setAttribute( "value", ( new Date() ).getTime() );</script></p></form> </div>
</div> 
</div>
</div>
<div class="td-pb-span4 td-main-sidebar" role="complementary">
<div class="td-ss-main-sidebar">
<aside id="block-5" class="td_block_template_1 widget block-5 widget_block"><div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6529061836735688" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="6302694057"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside>
<aside id="recent-posts-3" class="td_block_template_1 widget recent-posts-3 widget_recent_entries">
<h4 class="block-title"><span>Recent Posts</span></h4>
<ul>
<li>
<a href="https://www.somagnews.com/coach-max-waldo-has-parted-ways-with-cloud9/">Coach Max Waldo Has Parted Ways With Cloud9</a>
</li>
<li>
<a href="https://www.somagnews.com/chuck-d-says-public-enemy-have-been-harassed-by-the-police-more-than-any-of-the-musicians/" aria-current="page">Chuck D Says: &#8220;Public Enemy Have Been Harassed By The Police More Than Any of The Musicians&#8221;</a>
</li>
<li>
<a href="https://www.somagnews.com/liiv-sandbox-signs-contract-with-lcks-first-female-player-dangmoo/">Liiv SANDBOX Signs Contract With LCK&#8217;s First Female Player, DangMoo</a>
</li>
<li>
<a href="https://www.somagnews.com/v-from-bts-shows-off-her-riding-skills-behind-the-scenes-of-me-myself-and-v-veautiful-days/">V From BTS Shows Off Her Riding Skills Behind The Scenes of &#8220;Me, Myself, and V&#8221; &#8220;Veautiful Days&#8221;.</a>
</li>
<li>
<a href="https://www.somagnews.com/megans-allison-williams-the-daughter-of-brian-williams-has-just-weighed-in-on-how-she-felt-as-a-child-not-beyond-the-industry/">M3GAN&#8217;s Allison Williams, The Daughter of Brian Williams, Has Just Weighed in on How She Felt As a Child-Not Beyond The Industry</a>
</li>
<li>
<a href="https://www.somagnews.com/eric-ten-hag-confirms-manchester-uniteds-january-hunt-for-striker/">Eric ten Hag Confirms Manchester United&#8217;s January Hunt For Striker</a>
</li>
<li>
<a href="https://www.somagnews.com/i-want-to-be-honest-global-star-lil-nas-x-once-chose-his-side-in-the-famous-debate-between-kanye-west-and-drake-and-the-answer-is-shocking/">&#8220;I want to be honest&#8221; — Global Star Lil Nas X Once Chose His Side in The Famous Debate Between Kanye West and Drake, and The Answer Is Shocking</a>
</li>
<li>
<a href="https://www.somagnews.com/brian-johnson-would-be-ready-to-write-new-music-for-ac-dc/">Brian Johnson &#8220;Would Be Ready&#8221; to Write New Music For AC/DC</a>
</li>
<li>
<a href="https://www.somagnews.com/the-boyz-yonghoon-got-an-offensive-dm-due-to-vocal-problems/">THE BOYZ Yonghoon Got an Offensive DM Due to Vocal Problems</a>
</li>
<li>
<a href="https://www.somagnews.com/jang-gyuri-net-worth-2022-how-rich-is-the-former-vocalist-fromis_9/">Jang Gyuri Net Worth 2022: How Rich Is The Former Vocalist fromis_9?</a>
</li>
</ul>
</aside><aside id="block-6" class="td_block_template_1 widget block-6 widget_block"><div align="center"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6529061836735688" crossorigin="anonymous"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-6529061836735688" data-ad-slot="6302694057"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="block-3" class="td_block_template_1 widget block-3 widget_block widget_text">
<p></p>
</aside> </div>
</div>
</div> 
</div> 
</div> 

<div class="tdc-footer-wrap ">

<div class="td-footer-wrapper td-footer-container td-container-wrap td-footer-template-14 ">
<div class="td-container td-footer-bottom-full">
<div class="td-pb-row">
<div class="td-pb-span3"><aside class="footer-logo-wrap"><a href="https://www.somagnews.com/"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIyODEiIGhlaWdodD0iOTciIHZpZXdCb3g9IjAgMCAyODEgOTciPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNmZmZmZmYiLz48L3N2Zz4=" class="td-retina-data" data-src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" alt="" title="" width="281" height="97" /><noscript><img class="td-retina-data" src="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-13.png" data-retina="https://www.somagnews.com/wp-content/uploads/2021/11/SOMAG-logo-final-11-300x100.png" alt="" title=""  width="281" height="97" /></noscript></a></aside></div><div class="td-pb-span5"><aside class="footer-text-wrap"><div class="block-title"><span>ABOUT US</span></div>Somag News is an online international news platform that founded in 2019 with a dynamic news team.Our news team includes reporters that has a speciality in different fields from each other.<div class="footer-email-wrap">Contact us: <a href="/cdn-cgi/l/email-protection#244d4a424b64574b4945434a4153570a474b49"><span class="__cf_email__" data-cfemail="4b22252d240b3824262a2c252e3c3865282426">[email&#160;protected]</span></a></div></aside></div><div class="td-pb-span4"><aside class="footer-social-wrap td-social-style-2"><div class="block-title"><span>FOLLOW US</span></div>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://www.facebook.com/somagnews/" title="Facebook">
<i class="td-icon-font td-icon-facebook"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="/cdn-cgi/l/email-protection#ff96919990bf8c90929e98919a888cd19c9092" title="Mail">
<i class="td-icon-font td-icon-mail-1"></i>
</a>
</span>
<span class="td-social-icon-wrap">
<a target="_blank" href="https://twitter.com/SoMagNews" title="Twitter">
<i class="td-icon-font td-icon-twitter"></i>
</a>
</span></aside></div> </div>
</div>
</div>

<div class="td-sub-footer-container td-container-wrap ">
<div class="td-container">
<div class="td-pb-row">
<div class="td-pb-span td-sub-footer-menu">
<div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="td-subfooter-menu"><li id="menu-item-192159" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-first td-menu-item td-normal-menu menu-item-192159"><a href="https://www.somagnews.com/about-us/">About Us</a></li>
<li id="menu-item-191816" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191816"><a href="https://www.somagnews.com/advertise/">Advertise</a></li>
<li id="menu-item-191815" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191815"><a href="https://www.somagnews.com/advertisement-policy/">Advertisement Policy</a></li>
<li id="menu-item-191817" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191817"><a href="https://www.somagnews.com/terms-and-conditions/">Terms and Conditions</a></li>
<li id="menu-item-191818" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191818"><a href="https://www.somagnews.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-191819" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191819"><a href="https://www.somagnews.com/imprint/">Imprint</a></li>
<li id="menu-item-191820" class="menu-item menu-item-type-post_type menu-item-object-page td-menu-item td-normal-menu menu-item-191820"><a href="https://www.somagnews.com/contact/">Contact</a></li>
</ul></div> </div>
<div class="td-pb-span td-sub-footer-copy">
</div>
</div>
</div>
</div>
</div>
</div>
<div class="td-more-articles-box">
<i class="td-icon-close td-close-more-articles-box"></i>
<span class="td-more-articles-box-title">MORE STORIES</span>
<div class="td-content-more-articles-box">
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.somagnews.com/the-finale-of-netflixs-the-watcher-provoked-a-strong-reaction-on-twitter-the-worst-finale-ive-ever-seen/" rel="bookmark" class="td-image-wrap " title="The Finale of Netflix&#8217;s &#8220;The Watcher&#8221; Provoked a Strong Reaction on Twitter: &#8220;The worst finale I&#8217;ve ever seen&#8221;"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iNzAiIHZpZXdCb3g9IjAgMCAxMDAgNzAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNmZmZmZmYiLz48L3N2Zz4=" width="100" height="70" class="entry-thumb" data-src="https://www.somagnews.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png" alt="" /><noscript><img width="100" height="70" class="entry-thumb" src="https://www.somagnews.com/wp-content/plugins/td-standard-pack/Newspaper/assets/images/no-thumb/td_100x70.png"  alt="" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/the-finale-of-netflixs-the-watcher-provoked-a-strong-reaction-on-twitter-the-worst-finale-ive-ever-seen/" rel="bookmark" title="The Finale of Netflix&#8217;s &#8220;The Watcher&#8221; Provoked a Strong Reaction on Twitter: &#8220;The worst finale I&#8217;ve ever seen&#8221;">The Finale of Netflix&#8217;s &#8220;The Watcher&#8221; Provoked a Strong Reaction on...</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-10-18T16:51:41+00:00">October 18, 2022</time></span> </div>
</div>
</div>
<div class="td_module_6 td_module_wrap td-animation-stack">
<div class="td-module-thumb"><a href="https://www.somagnews.com/buffys-replacement-slayer-is-corrupted-by-her-power/" rel="bookmark" class="td-image-wrap " title="Buffy&#8217;s replacement Slayer is corrupted by her Power"><img data-lazyloaded="1" src="data:image/svg+xml;base64,PHN2ZyB4bWxucz0iaHR0cDovL3d3dy53My5vcmcvMjAwMC9zdmciIHdpZHRoPSIxMDAiIGhlaWdodD0iNzAiIHZpZXdCb3g9IjAgMCAxMDAgNzAiPjxyZWN0IHdpZHRoPSIxMDAlIiBoZWlnaHQ9IjEwMCUiIGZpbGw9IiNmZmZmZmYiLz48L3N2Zz4=" width="100" height="70" class="entry-thumb" data-src="https://www.somagnews.com/wp-content/uploads/2022/07/buffy__039_s_replacement_slayer_is_being_corrupted_by_her_power_-100x70.jpg" data-srcset="https://www.somagnews.com/wp-content/uploads/2022/07/buffy__039_s_replacement_slayer_is_being_corrupted_by_her_power_-100x70.jpg 100w, https://www.somagnews.com/wp-content/uploads/2022/07/buffy__039_s_replacement_slayer_is_being_corrupted_by_her_power_-218x150.jpg 218w" data-sizes="(max-width: 100px) 100vw, 100px" alt="" title="Buffy&#8217;s replacement Slayer is corrupted by her Power" /><noscript><img width="100" height="70" class="entry-thumb" src="https://www.somagnews.com/wp-content/uploads/2022/07/buffy__039_s_replacement_slayer_is_being_corrupted_by_her_power_-100x70.jpg"  srcset="https://www.somagnews.com/wp-content/uploads/2022/07/buffy__039_s_replacement_slayer_is_being_corrupted_by_her_power_-100x70.jpg 100w, https://www.somagnews.com/wp-content/uploads/2022/07/buffy__039_s_replacement_slayer_is_being_corrupted_by_her_power_-218x150.jpg 218w" sizes="(max-width: 100px) 100vw, 100px"  alt="" title="Buffy&#8217;s replacement Slayer is corrupted by her Power" /></noscript></a></div>
<div class="item-details">
<h3 class="entry-title td-module-title"><a href="https://www.somagnews.com/buffys-replacement-slayer-is-corrupted-by-her-power/" rel="bookmark" title="Buffy&#8217;s replacement Slayer is corrupted by her Power">Buffy&#8217;s replacement Slayer is corrupted by her Power</a></h3> <div class="td-module-meta-info">
<span class="td-post-date"><time class="entry-date updated td-module-date" datetime="2022-07-01T18:04:24+00:00">July 1, 2022</time></span> </div>
</div>
</div>
</div>
</div>

<div class="td-container"><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-ad-client="ca-pub-6529061836735688" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</div><script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/contact-form-7/includes/swv/js/index.js?ver=5.7.1' id='swv-js'></script>
<script type='text/javascript' id='contact-form-7-js-extra'>
/* <![CDATA[ */
var wpcf7 = {"api":{"root":"https:\/\/www.somagnews.com\/wp-json\/","namespace":"contact-form-7\/v1"},"cached":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/contact-form-7/includes/js/index.js?ver=5.7.1' id='contact-form-7-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/td-composer/legacy/Newspaper/js/tagdiv_theme.min.js?ver=12.1.1' id='td-site-min-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/comment-reply.min.js?ver=afb24994d1a83bf9201f947f3160754b' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.somagnews.com/wp-includes/js/underscore.min.js?ver=1.13.4' id='underscore-js'></script>
<script type='text/javascript' id='tds_js_files_for_front-js-extra'>
/* <![CDATA[ */
var tds_js_globals = {"wpRestNonce":"8d581024cc","wpRestUrl":"https:\/\/www.somagnews.com\/wp-json\/","permalinkStructure":"\/%postname%\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/td-subscription/assets/js/js_files_for_front.min.js?ver=1.3.3' id='tds_js_files_for_front-js'></script>
<script defer type='text/javascript' src='https://www.somagnews.com/wp-content/plugins/akismet/_inc/akismet-frontend.js?ver=1671926577' id='akismet-frontend-js'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>

<script>
    
</script>
<script data-no-optimize="1">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</script></body>
</html>
